Anuncios

domingo, 21 de noviembre de 2021

¿Que es, para que sirve y como usar la función BUSCAR X en Excel? Ejercicios desde Cero hasta Avanzado

Aprende a utilizar la función BUSCARX desde Cero hasta nivel Experto. Ahora si no cuentas con la función BUSCARX no te preocupes porque te enseño como puedes llegar al mismo resultado combinando las funciones de BUSCARV, BUSCARH, INDICE y COINCIDIR.

como usar la funcion BUSCARX en excel

¿Qué es la función BUSCARX en Excel y para que sirve?

La función BUSCARX es una de las herramientas mas importantes para realizar búsquedas en Excel y hace parte de las nuevas funciones matriciales de office365 y office 2021.


La función BUSCARX es una función que realiza búsquedas a nivel matricial y pertenece a la categoría de Funciones de Búsqueda y Referencias y la formula busca una coincidencia en un rango o una matriz y devuelve el elemento correspondiente de un segundo rango o matriz. De forma predeterminada, se usa una coincidencia exacta.


Te recomiendo el siguiente video donde te explico el paso a paso para utilizar la función BUSCARX desde cero hasta Avanzado y en la parte inferior del articulo puedes DESCARGAR el material para que puedas practicar el paso a paso.



¿No me aparece la función BUSCARX y como puedo activarla en Excel?


Te has realizado esta pregunta cuando quieres explorar las nuevas funciones de excel como en este caso la función BUSCARX debes de tener presente que para contar con las nuevas funciones de Excel debemos de tener Office365 o el nuevo Office 2021, esta función no se cuenta en versiones anteriores como  2019, 2016 etc.


¿Cuáles son los argumentos de la función BUSCARX de Excel?

Para acceder a la función BUSCARX en la categoría Búsqueda y referencia encontramos la función

argumentos de la función BUSCARX en excel

Como argumentos tenemos los siguientes.

argumentos de la función BUSCARX en excel

Valor_Buscado: En este campo colocamos o seleccionamos el valor buscado.


Matriz_Busqueda: En este argumento seleccionamos el rango donde vamos a buscar el valor buscado


Matriz_Devuelta: En este campo seleccionamos el rango que queremos como resultado del valor buscado


Si_No_Se_Encuentra: Este argumento es opcional y teniendo en cuenta sí no encuentra el valor buscado aplicar otra acción. Este argumento por defecto arroja #N/D


Modo_de_Coincidencia: Este argumento por defecto siempre será coincidencia exacta, pero podemos colocar la opción de Coincidencia Exacta, Exacta o siguiente mas pequeño, Exacta o siguiente mas grande, buscar con comodines.


Modo_de_Busqueda: Este argumento por defecto siempre será del primero al ultimo, pero podemos colocar la opción primero al ultimo, del ultimo al primero, binaria ascendente, binaria descendente.


Como usar la función BUSCAR X en Excel con Ejercicios


En el siguiente ENLACE puedes DESCARGAR el material para que puedas realizar los ejercicios.


Búsqueda de manera vertical con la función BUSCARX


Como pueden ver en el siguiente ejercicio tenemos el nombre, año y salario y queremos buscar el nombre de Diana.


La formula sería =BUSCARX(F9;A9:A15;C9:C15)

como usar la función BUSCARX en excel


Como resultado sería $3.343 pero este ejercicio también lo podemos realizar con la función BUSCARV, =BUSCARV(F12;A9:C15;3;0)


como usar la función BUSCARX en excel


Búsqueda de manera Horizontal con la función BUSCARX


Como pueden ver en el siguiente ejercicio tenemos el nombre, año y salario y queremos buscar el nombre de Diana.


La formula sería =BUSCARX(D10;B5:H5;B7:H7)


como usar la funcion buscarx en excel

Como resultado sería $5.234 pero este ejercicio también lo podemos realizar con la función BUSCARH, =BUSCARH(D14;B5:H7;3;0)


como usar la funcion buscarx en excel


¿Cómo buscar datos de derecha a izquierda con la función BUSCARX en Excel?


Como pueden ver en el siguiente ejercicio tenemos el nombre, año y salario y queremos buscar el código A004 y queremos como resulta el nombre que se encuentra al lado izquierdo del valor buscado.


La formula sería =BUSCARX(H7;D8:D14;B8:B14)


Cómo buscar datos de derecha a izquierda con la función BUSCARX en Excel


Como resultado sería Diana pero este ejercicio también lo podemos realizar de la siguiente manera, =INDICE(B8:D14;COINCIDIR(H11;D8:D14;0);1)


Cómo buscar datos de derecha a izquierda con la función BUSCARX en Excel




Seguramente quieres sabes más acerca de Excel, no te olvides darte una vuelta por las siguientes secciones disponibles para ti de manera gratuita: 


Canal de YouTube
Comunidad Telegram
Instagram: Aprende y Enseña Excel
Facebook: Aprende Excel Fácil
Twitter: Aprende y Enseña Excel


Hasta una próxima y te deseo el mayor de los EXITOS.


Aprende y Enseña Excel.






No hay comentarios:

Publicar un comentario