Anuncios

miércoles, 21 de octubre de 2020

Validar una Celda que Permita solo NÚMEROS o TEXTO con un MÍNIMO y un MÁXIMO de CARACTERES en Excel

Aprende a validar datos y celdas que permita solo texto o números con un mínimo y un máximo de caracteres o dígitos. El video nos permitirá validar celdas, filas, o columnas con tres criterios o condiciones

¿Cómo Validar una Celda que permita solo números o texto con un mínimo y un máximo de caracteres en Excel?

En ocasiones queremos proteger una celda, un rango, un formulario o una base de datos y no queremos que introduzcan o digiten datos que no queremos es decir que utilicemos una validación para que permita escribir en una celda solo números o solo texto pero con una particularidad que cumpla con cierta cantidad de caracteres y para excel cuenta con una herramienta de VALIDACIÓN DE DATOS y la combinación de dos funciones, FUNCIÓN SI anidada con Y y O, y función LARGO. Hay que tener presente que para realizar lo anterior debe de ser con criterios personalizados.


En el siguiente video se explica como utilizar la validación personalizada en excel.



Te dejo los siguientes ENLACES para que profundices sobre las siguiente herramientas VALIDACIÓN DE DATOSFUNCIÓN SI y FUNCION ANIDADA(Y-O, FUNCIÓN LARGO


Para poder utilizar la validación de datos lo encontramos en la pestaña de menú Datos, nos dirigimos hacia el grupo de Herramientas de datos y presionamos clic en el icono de validación de datos.

validación de celdas en excel

Nos abre la ventana de validación de datos.

validación de celdas en excel


En la opción de permitir seleccionamos la opción de personalizada.


validación de celdas en excel

Para entender este proceso lo vamos a realizar con un ejercicio practico, pero es importante que se debe tener un previo conocimiento de la función SI, ANIDACIONES con Y y O, función LARGO y de la herramienta validación de datos, recomiendo que acceda a los enlaces para que profundizar sobre estos temas porque se considera que para resolver este ejercicio ya conocen las herramientas.


Tenemos esta información y en la columna B2 vamos a validar la celda para que permita solo texto con cinco y diez caracteres en excel


validación de celdas en excel

Entonces seleccionamos la celda, el rango o la columna B y nos dirigimos a la ventana de validación de datos como se explica en el procedimiento anterior.


En el criterio personalizado se nos habilita la casilla para la formula y vamos a utilizar la siguiente formula =SI(Y(ESTEXTO(B2);LARGO(B2)>=5;LARGO(B2)<=10);VERDADERO;FALSO) donde estamos diciendo que si a celda B2 es igual texto y tiene mas de 5 a 10 caracteres lo permita de lo contrario no lo permita en la celda y presionamos aceptar.


validación de celdas en excel


Como se muestra en la siguiente imagen en la celda B1 escribimos la palabra Excel y me permite ingresarlo porque hace parte de la condición que asignamos pero si coloco la palabra hola me sale el error porque no hace parte de las letras validadas.


validación de celdas en excel


validación de celdas en excel

Continuando con el ejercicio para validar la celda B3 para que permita solo número con 3 a 5 caracteres. La formula sería la siguiente =SI(Y(ESNUMERO(B3);LARGO(B3)>=3;LARGO(B3)<=5);VERDADERO;FALSO) y presionamos aceptar


validación de celdas en excel

Ahora probemos la validación si digito 12345 me lo permite porque hace parte de dentro de la validación pero si escribo 123456 me aparece el error porque no hace parte de la mismo a sair




validación de celdas en excel



validación de celdas en excel



Seguramente quieres sabes más acerca de Excel, no te olvides darte una vuelta por las siguientes secciones disponibles para ti de manera gratuita


Canal de YouTube
Comunidad Telegram
Instagram: Aprende y Enseña Excel
Facebook: Aprende y Enseña Excel
Twitter: Aprende y Enseña Excel

No hay comentarios:

Publicar un comentario